What’s Vulnerable › Vulnerabilities
CVE-2025-27831
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-25 · updated 2026-06-17
- Weakness: CWE-120
Description
An issue was discovered in Artifex Ghostscript before 10.05.0. The DOCXWRITE TXTWRITE device has a text buffer overflow via long characters to devices/vector/doc_common.c.
Affected products
- Artifex Ghostscript: before 10.05.0 — fixed in 10.05.0
How to fix
Upgrade to a fixed version: Artifex Ghostscript 10.05.0. Check the vendor advisory for mitigations.
References
- https://bugs.ghostscript.com/show_bug.cgi?id=708132
- https://lists.debian.org/debian-lts-announce/2025/04/msg00014.html
Get alerted when CVE-2025-27831 or the next vulnerability affects your stack