What’s Vulnerable › Vulnerabilities
CVE-2025-27834
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-25 · updated 2026-06-17
- Weakness: CWE-120
Description
An issue was discovered in Artifex Ghostscript before 10.05.0. A buffer overflow occurs via an oversized Type 4 function in a PDF document to pdf/pdf_func.c.
Affected products
- Artifex Ghostscript: before 10.05.0 — fixed in 10.05.0
How to fix
Upgrade to a fixed version: Artifex Ghostscript 10.05.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-27834 or the next vulnerability affects your stack