What’s Vulnerable › Vulnerabilities
CVE-2025-2784: Libsoup: heap buffer over-read in `skip_insignificant_space` when sniffing content
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-03 · updated 2026-06-30
- Weakness: CWE-125
Description
A flaw was found in libsoup. The package is vulnerable to a heap buffer over-read when sniffing content via the skip_insight_whitespace() function. Libsoup clients may read one byte out-of-bounds in response to a crafted HTTP response by an HTTP server.
Affected products
- GNOME libsoup: before 3.6.5 — fixed in 3.6.5
- RedHat Codeready Linux Builder: 10.0
- RedHat Codeready Linux Builder For Arm64: 10.0_aarch64
- RedHat Codeready Linux Builder For Arm64 Eus: 10.0_aarch64
- RedHat Codeready Linux Builder For Ibm Z Systems: 10.0_s390x
- RedHat Codeready Linux Builder For Ibm Z Systems Eus: 10.0_s390x
- RedHat Codeready Linux Builder For Power Little Endian: 10.0_ppc64le
- RedHat Codeready Linux Builder For Power Little Endian Eus: 10.0_ppc64le
- Red Hat Enterprise Linux: 8.0, 9.0, 10.0
- RedHat Enterprise Linux Eus: 8.8, 9.2, 9.4, 9.6, 10.0
- RedHat Enterprise Linux For Arm 64: 8.0_aarch64, 9.0_aarch64, 10.0_aarch64
- RedHat Enterprise Linux For Arm 64 Eus: 8.8_aarch64, 9.2_aarch64, 9.4_aarch64, 9.6_aarch64, 10.0_aarch64
- RedHat Enterprise Linux For Ibm Z Systems: 8.0_s390x, 9.0_s390x, 10.0_s390x
- RedHat Enterprise Linux For Ibm Z Systems Eus: 8.8_s390x, 9.2_s390x, 9.4_s390x, 9.6_s390x, 10.0_s390x
- RedHat Enterprise Linux For Power Little Endian: 8.0_ppc64le, 9.0_ppc64le, 10.0_ppc64le
- RedHat Enterprise Linux For Power Little Endian Eus: 8.8_ppc64le, 9.2_ppc64le, 9.4_ppc64le, 9.6_ppc64le, 10.0_ppc64le
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 8.2, 8.4, 8.6, 9.2, 9.4, 9.6
- RedHat Enterprise Linux Server For Power Little Endian Update Services For Sap Solutions: 8.6_ppc64le, 9.0_ppc64le, 9.6_ppc64le
- RedHat Enterprise Linux Server Tus: 8.6, 8.8
- RedHat Enterprise Linux Update Services For Sap Solutions: 8.8, 9.0, 9.2, 9.4, 9.6
How to fix
Upgrade to a fixed version: GNOME libsoup 3.6.5. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2025:21657
- https://access.redhat.com/errata/RHSA-2025:7505
- https://access.redhat.com/errata/RHSA-2025:8126
- https://access.redhat.com/errata/RHSA-2025:8132
- https://access.redhat.com/errata/RHSA-2025:8139
- https://access.redhat.com/errata/RHSA-2025:8140
- https://access.redhat.com/errata/RHSA-2025:8252
- https://access.redhat.com/errata/RHSA-2025:8480
- https://access.redhat.com/errata/RHSA-2025:8481
- https://access.redhat.com/errata/RHSA-2025:8482
- https://access.redhat.com/errata/RHSA-2025:8663
- https://access.redhat.com/errata/RHSA-2025:9179
Get alerted when CVE-2025-2784 or the next vulnerability affects your stack