What’s Vulnerable › Vulnerabilities
CVE-2025-27867: Apache Felix HTTP Webconsole Plugin: XSS in HTTP Webconsole Plugin
- Severity: medium (CVSS 5.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-12 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Felix HTTP Webconsole Plugin. This issue affects Apache Felix HTTP Webconsole Plugin: from Version 1.X through 1.2.0. Users are recommended to upgrade to version 1.2.2, which fixes the issue.
Affected products
- Apache Software Foundation Apache Felix HTTP Webconsole Plugin: from 1.0.0 before 1.2.2 — fixed in 1.2.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Felix HTTP Webconsole Plugin 1.2.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/y83f2rvm8bccr5ctgv7mzxd69p6f77dp
- http://www.openwall.com/lists/oss-security/2025/03/12/3
Get alerted when CVE-2025-27867 or the next vulnerability affects your stack