What’s Vulnerable › Vulnerabilities

CVE-2025-2787: Ingress-nginx vulnerability in KNIME Business Hub

Description

KNIME Business Hub is affected by the Ingress-nginx CVE-2025-1974 ( a.k.a IngressNightmare ) vulnerability which affects the ingress-nginx component. In the worst case a complete takeover of the Kubernetes cluster is possible. Since the affected component is only reachable from within the cluster, i.e. requires an authenticated user, the severity in the context of KNIME Business Hub is slightly lower. Besides applying the publicly known workarounds, we strongly recommend updating to one of the following versions of KNIME Business Hub: * 1.13.3 or above * 1.12.4 or above * 1.11.4 or above * 1.10.4 or above *

Affected products

How to fix

Upgrade to a fixed version: KNIME Business Hub 1.10.4, 1.11.4, 1.12.4, 1.13.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-2787 or the next vulnerability affects your stack