What’s Vulnerable › Vulnerabilities
CVE-2025-27912
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-11 · updated 2026-06-17
- Weakness: CWE-352
Description
An issue was discovered in Datalust Seq before 2024.3.13545. Missing Content-Type validation can lead to CSRF when (1) Entra ID or OpenID Connect authentication is in use and a user visits a compromised/malicious site, or (2) when username/password or Active Directory authentication is in use and a user visits a compromised/malicious site under the same effective top-level domain as the Seq server. Exploitation of the vulnerability allows the attacker to conduct impersonation attacks and perform actions in Seq on behalf of the targeted user.
Affected products
- Datalust Seq: before 2024.3.13545 — fixed in 2024.3.13545
How to fix
Upgrade to a fixed version: Datalust Seq 2024.3.13545. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-27912 or the next vulnerability affects your stack