What’s Vulnerable › Vulnerabilities
CVE-2025-27918
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-06 · updated 2026-06-17
- Weakness: CWE-190
Description
An issue was discovered in AnyDesk for Windows before 9.0.5, AnyDesk for macOS before 9.0.1, AnyDesk for Linux before 7.0.0, AnyDesk for iOS before 7.1.2, and AnyDesk for Android before 8.0.0. It has an integer overflow and resultant heap-based buffer overflow via a UDP packet during processing of an Identity user image within the Discovery feature, or when establishing a connection between any two clients.
Affected products
- AnyDesk: before 9.0.0 — fixed in 9.0.0
How to fix
Upgrade to a fixed version: AnyDesk 9.0.0. Check the vendor advisory for mitigations.
References
- https://anydesk.com/en/changelog/windows
- https://dspace.cvut.cz/bitstream/handle/10467/122721/F8-DP-2025-Krejsa-Vojtech-DP_Krejsa_Vojtech_2025.pdf
Get alerted when CVE-2025-27918 or the next vulnerability affects your stack