What’s Vulnerable › Vulnerabilities

CVE-2025-2793: IBM Sterling B2B Integrator and IBM Sterling File Gateway cross-site scripting

Description

IBM Sterling B2B Integrator 6.0.0.0 through 6.1.2.6, 6.2.0.0 through 6.2.0.4, IBM Sterling File Gateway 6.0.0.0 through 6.1.2.6, and 6.2.0.0 through 6.2.0.4 is vulnerable to cross-site scripting. This vulnerability allows an authenticated user to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session.

Affected products

How to fix

Upgrade to a fixed version: IBM Sterling B2B Integrator 6.1.2.7_1, 6.2.0.5; IBM Sterling File Gateway 6.1.2.7_1, 6.2.0.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-2793 or the next vulnerability affects your stack