What’s Vulnerable › Vulnerabilities
CVE-2025-2798: Woffice <= 5.4.21 - Authentication Bypass via Registration Role
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-04 · updated 2026-06-17
- Weakness: CWE-269
Description
The Woffice CRM theme for WordPress is vulnerable to Authentication Bypass in all versions up to, and including, 5.4.21. This is due to a misconfiguration of excluded roles during registration. This makes it possible for unauthenticated attackers to register with an Administrator role if a custom login form is being used. This can be combined with CVE-2025-2797 to bypass the user approval process if an Administrator can be tricked into taking an action such as clicking a link.
Affected products
- WofficeIO Woffice Core: before 5.4.22 — fixed in 5.4.22
How to fix
Upgrade to a fixed version: WofficeIO Woffice Core 5.4.22. Check the vendor advisory for mitigations.
References
- https://hub.woffice.io/woffice/changelog#april-1st-2025-version-5422
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6dd6169b-bc94-4642-8975-2e96bc01576f?source=cve
Get alerted when CVE-2025-2798 or the next vulnerability affects your stack