What’s Vulnerable › Vulnerabilities
CVE-2025-2799: WP Event Manager <= 3.1.49 - Authenticated (Administrator+) Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Event Manager – Events Calendar, Registrations, Sell Tickets with WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘tag-name’ parameter in all versions up to, and including, 3.1.49 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Affected products
- wpeventmanager WP Event Manager – Events Calendar, Registrations, Sell Tickets with WooCommerce: before 3.1.50 — fixed in 3.1.50
How to fix
Upgrade to a fixed version: wpeventmanager WP Event Manager – Events Calendar, Registrations, Sell Tickets with WooCommerce 3.1.50. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3309197/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/a5cb5ab0-2110-49be-bc09-6847065a9dd9?source=cve
Get alerted when CVE-2025-2799 or the next vulnerability affects your stack