What’s Vulnerable › Vulnerabilities
CVE-2025-28073
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-08 · updated 2026-06-17
- Weakness: CWE-79
Description
phpList before 3.6.15 is vulnerable to Reflected Cross-Site Scripting (XSS) via the /lists/dl.php endpoint. An attacker can inject arbitrary JavaScript code by manipulating the id parameter, which is improperly sanitized.
Affected products
- PHPList: before 3.6.15 — fixed in 3.6.15
How to fix
Upgrade to a fixed version: PHPList 3.6.15. Check the vendor advisory for mitigations.
References
- https://github.com/mLniumm/CVE-2025-28073
- https://github.com/phpList/phplist3
- https://github.com/phpList/phplist3/compare/v3.6.14...v3.6.15
- https://www.phplist.org/newslist/phplist-3-6-15-release-notes/
Get alerted when CVE-2025-28073 or the next vulnerability affects your stack