What’s Vulnerable › Vulnerabilities
CVE-2025-2817: Privilege escalation in Thunderbird Updater
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-29 · updated 2026-10-05
- Weakness: CWE-22
Description
Thunderbird's update mechanism allowed a medium-integrity user process to interfere with the SYSTEM-level updater by manipulating the file-locking behavior. By injecting code into the user-privileged process, an attacker could bypass intended access controls, allowing SYSTEM-level file operations on paths controlled by a non-privileged user and enabling privilege escalation. This vulnerability was fixed in Firefox 138, Firefox ESR 128.10, Firefox ESR 115.23, Thunderbird 138, and Thunderbird 128.10.
Affected products
- Mozilla Firefox: before 115.23.0; before 138.0; from 116.0 before 128.10.0 — fixed in 115.23.0, 128.10.0, 138.0
- Mozilla Thunderbird: before 128.10.0; from 129.0 before 138.0 — fixed in 128.10.0, 138.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 115.23.0, 128.10.0, 138.0; Mozilla Thunderbird 128.10.0, 138.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1917536
- https://www.mozilla.org/security/advisories/mfsa2025-28/
- https://www.mozilla.org/security/advisories/mfsa2025-29/
- https://www.mozilla.org/security/advisories/mfsa2025-30/
- https://www.mozilla.org/security/advisories/mfsa2025-31/
- https://www.mozilla.org/security/advisories/mfsa2025-32/
- https://lists.debian.org/debian-lts-announce/2025/05/msg00022.html
Get alerted when CVE-2025-2817 or the next vulnerability affects your stack