What’s Vulnerable › Vulnerabilities
CVE-2025-28254
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross Site Scripting vulnerability in Leantime v3.2.1 and before allows an authenticated attacker to execute arbitrary code and obtain sensitive information via the first name field in processMentions().
Affected products
- Leantime: before 3.3.0 — fixed in 3.3.0
How to fix
Upgrade to a fixed version: Leantime 3.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/Leantime/leantime/blob/0e7ddbbe3d582f657a1dddfef7b3419ae588cbf7/app/Domain/Notifications/Services/Notifications.php#L128
- https://github.com/Leantime/leantime/commit/ce1d2073e4601183e1bdd90f4b433d16aee46a50
- https://github.com/Leantime/leantime/security/advisories/GHSA-95j3-435g-vjcp
Get alerted when CVE-2025-28254 or the next vulnerability affects your stack