What’s Vulnerable › Vulnerabilities
CVE-2025-2828: SSRF Vulnerability in RequestsToolkit in langchain-ai/langchain
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 21.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-23 · updated 2026-06-17
- Weakness: CWE-918
Description
A Server-Side Request Forgery (SSRF) vulnerability exists in the RequestsToolkit component of the langchain-community package (specifically, langchain_community.agent_toolkits.openapi.toolkit.RequestsToolkit) in langchain-ai/langchain version 0.0.27. This vulnerability occurs because the toolkit does not enforce restrictions on requests to remote internet addresses, allowing it to also access local addresses. As a result, an attacker could exploit this flaw to perform port scans, access local services, retrieve instance metadata from cloud environments (e.g., Azure, AWS), and interact with servers on the local network. This issue has been fixed in version 0.0.28.
Affected products
- langchain-ai/langchain: before 0.0.28 — fixed in 0.0.28
How to fix
Upgrade to a fixed version: langchain-ai/langchain 0.0.28. Check the vendor advisory for mitigations.
References
- https://github.com/langchain-ai/langchain/commit/e188d4ecb085d4561a0be3c583d26aa9c2c3283f
- https://huntr.com/bounties/8f771040-7f34-420a-b96b-5b93d4a99afc
- https://huntr.com/bounties/8f771040-7f34-420a-b96b-5b93d4a99afc
Get alerted when CVE-2025-2828 or the next vulnerability affects your stack