What’s Vulnerable › Vulnerabilities

CVE-2025-2853: Allocation of Resources Without Limits or Throttling in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions before 17.10.7, 17.11 before 17.11.3, and 18.0 before 18.0.1. A lack of proper validation in GitLab could allow an authenticated user to cause a denial of service condition.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.10.7, 17.11.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-2853 or the next vulnerability affects your stack