What’s Vulnerable › Vulnerabilities
CVE-2025-2867: Improper Control of Generation of Code ('Code Injection') in GitLab
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-27 · updated 2026-06-17
- Weakness: CWE-94
Description
An issue has been discovered in the GitLab Duo with Amazon Q affecting all versions from 17.8 before 17.8.6, 17.9 before 17.9.3, and 17.10 before 17.10.1. A specifically crafted issue could manipulate AI-assisted development features to potentially expose sensitive project data to unauthorized users.
Affected products
- GitLab: from 17.8.0 before 17.8.6; from 17.9.0 before 17.9.3; 17.10.0 — fixed in 17.8.6, 17.9.3
How to fix
Upgrade to a fixed version: GitLab 17.8.6, 17.9.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-2867 or the next vulnerability affects your stack