What’s Vulnerable › Vulnerabilities
CVE-2025-2876: MelaPress Login Security and MelaPress Login Security Premium 2.1.0 - Missing Authorization to Unauthenticated Arbitrary User Deletion
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-08 · updated 2026-06-17
- Weakness: CWE-862
Description
The MelaPress Login Security and MelaPress Login Security Premium plugins for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the 'monitor_admin_actions' function in version 2.1.0. This makes it possible for unauthenticated attackers to delete any user.
Affected products
- MelaPress Login Security: before 2.1.1 — fixed in 2.1.1
How to fix
Upgrade to a fixed version: MelaPress Login Security 2.1.1. Check the vendor advisory for mitigations.
References
- https://melapress.com/wordpress-login-security/releases/
- https://plugins.trac.wordpress.org/browser/melapress-login-security/trunk/app/modules/temporary-logins/class-temporary-logins.php#L71
- https://plugins.trac.wordpress.org/changeset/3267748/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/559cbc69-85b6-4bad-9bb2-26d64195ba7e?source=cve
Get alerted when CVE-2025-2876 or the next vulnerability affects your stack