What’s Vulnerable › Vulnerabilities
CVE-2025-29072
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-27 · updated 2026-06-17
- Weakness: CWE-190
Description
An integer overflow in Nethermind Juno before v.12.05 within the Sierra bytecode decompression logic within the "cairo-lang-starknet-classes" library could allow remote attackers to trigger an infinite loop (and high CPU usage) by submitting a malicious Declare v2/v3 transaction. This results in a denial-of-service condition for affected Starknet full-node implementations.
Affected products
- Nethermind Juno: before 0.12.5 — fixed in 0.12.5
How to fix
Upgrade to a fixed version: Nethermind Juno 0.12.5. Check the vendor advisory for mitigations.
References
- https://community.starknet.io/t/starknet-security-update-potential-full-node-vulnerability-recap/115314
- https://github.com/NethermindEth/juno/commit/51074875941aa111c5dd2b41f2ec890a4a15b587
Get alerted when CVE-2025-29072 or the next vulnerability affects your stack