What’s Vulnerable › Vulnerabilities
CVE-2025-29192
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-10-06 · updated 2026-10-09
- Weakness: CWE-79
Description
Flowise before 3.0.5 allows XSS via a FORM element and an INPUT element when an admin views the chat log.
Affected products
- FlowiseAI Flowise: before 3.0.5 — fixed in 3.0.5
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 3.0.5. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/pull/4905
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise%403.0.5
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-7r4h-vmj9-wg42
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-7r4h-vmj9-wg42
Get alerted when CVE-2025-29192 or the next vulnerability affects your stack