What’s Vulnerable › Vulnerabilities
CVE-2025-29331
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-26 · updated 2026-06-17
- Weakness: CWE-295
Description
An issue in MHSanaei 3x-ui before v.2.5.3 and before allows a remote attacker to execute arbitrary code via the management script x-ui passes the no check certificate option to wget when downloading updates
Affected products
- MHSanaei 3x-ui: before 2.5.3 — fixed in 2.5.3
How to fix
Upgrade to a fixed version: MHSanaei 3x-ui 2.5.3. Check the vendor advisory for mitigations.
References
- https://github.com/MHSanaei/3x-ui/pull/2661
- https://www.digilol.net/security-advisories/dlsec2025-001.html
Get alerted when CVE-2025-29331 or the next vulnerability affects your stack