What’s Vulnerable › Vulnerabilities

CVE-2025-2934: Allocation of Resources Without Limits or Throttling in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 5.2 prior to 18.2.8, 18.3 prior to 18.3.4, and 18.4 prior to 18.4.2 that could have allowed an authenticated attacker to create a denial of service condition by configuring malicious webhook endpoints that send crafted HTTP responses.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.2.8, 18.3.4, 18.4.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-2934 or the next vulnerability affects your stack