What’s Vulnerable › Vulnerabilities

CVE-2025-2937: Inefficient Regular Expression Complexity in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 13.2 before 18.0.6, 18.1 before 18.1.4, and 18.2 before 18.2.2 that could have allowed authenticated users to create a denial of service condition by sending specially crafted markdown payloads to the Wiki feature.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.0.6, 18.1.4, 18.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-2937 or the next vulnerability affects your stack