What’s Vulnerable › Vulnerabilities
CVE-2025-2938: Business Logic Errors in GitLab
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-26 · updated 2026-06-17
- Weakness: CWE-840
Description
An issue has been discovered in GitLab CE/EE affecting all versions from 17.3 before 17.11.5, 18.0 before 18.0.3, and 18.1 before 18.1.1 that could have allowed authenticated users to gain elevated project privileges by requesting access to projects where role modifications during the approval process resulted in unintended permission grants.
Affected products
- GitLab: from 17.3.0 before 17.11.5; from 18.0.0 before 18.0.3; 18.1.0 — fixed in 17.11.5, 18.0.3
How to fix
Upgrade to a fixed version: GitLab 17.11.5, 18.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-2938 or the next vulnerability affects your stack