What’s Vulnerable › Vulnerabilities
CVE-2025-29606
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-14 · updated 2026-06-17
- Weakness: CWE-770
Description
py-libp2p before 0.2.3 allows a peer to cause a denial of service (resource consumption) via a large RSA key.
Affected products
- libp2p py-libp2p: before 0.2.3 — fixed in 0.2.3
How to fix
Upgrade to a fixed version: libp2p py-libp2p 0.2.3. Check the vendor advisory for mitigations.
References
- https://github.com/libp2p/py-libp2p/compare/v0.2.2...v0.2.3
- https://github.com/libp2p/py-libp2p/issues/526
- https://github.com/libp2p/py-libp2p/pull/531/files
Get alerted when CVE-2025-29606 or the next vulnerability affects your stack