What’s Vulnerable › Vulnerabilities
CVE-2025-29768: Vim vulnerable to potential data loss with zip.vim and special crafted zip files
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-13 · updated 2026-06-17
- Weakness: CWE-88
Description
Vim, a text editor, is vulnerable to potential data loss with zip.vim and special crafted zip files in versions prior to 9.1.1198. The impact is medium because a user must be made to view such an archive with Vim and then press 'x' on such a strange filename. The issue has been fixed as of Vim patch v9.1.1198.
Affected products
- NetApp Bootstrap Os: all versions
- vim/vim: before 9.1.1198 — fixed in 9.1.1198
How to fix
Upgrade to a fixed version: vim/vim 9.1.1198. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/f209dcd3defb95bae21b2740910e6aa7bb940531
- https://github.com/vim/vim/security/advisories/GHSA-693p-m996-3rmf
- https://security.netapp.com/advisory/ntap-20250502-0001/
Get alerted when CVE-2025-29768 or the next vulnerability affects your stack