What’s Vulnerable › Vulnerabilities
CVE-2025-29772: OpenEMR allows Reflected XSS in CAMOS new.php
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-79
Description
OpenEMR is a free and open source electronic health records and medical practice management application. The POST parameter hidden_subcategory is output to the page without being properly processed. This leads to a reflected cross-site scripting (XSS) vul;nerability in CAMOS new.php. This vulnerability is fixed in 7.0.3.
Affected products
- openemr: before 7.0.3 — fixed in 7.0.3
How to fix
Upgrade to a fixed version: openemr 7.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/commit/17c5c424695de50db94f2c01fb9abfc441d09a1a
- https://github.com/openemr/openemr/security/advisories/GHSA-89gp-g4c9-hv8h
Get alerted when CVE-2025-29772 or the next vulnerability affects your stack