What’s Vulnerable › Vulnerabilities
CVE-2025-29783: vLLM Allows Remote Code Execution via Mooncake Integration
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-19 · updated 2026-06-17
- Weakness: CWE-502
Description
vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. When vLLM is configured to use Mooncake, unsafe deserialization exposed directly over ZMQ/TCP on all network interfaces will allow attackers to execute remote code on distributed hosts. This is a remote code execution vulnerability impacting any deployments using Mooncake to distribute KV across distributed hosts. This vulnerability is fixed in 0.8.0.
Affected products
- vllm-project vllm: from 0.6.5 before 0.8.0 — fixed in 0.8.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/288ca110f68d23909728627d3100e5a8db820aa2
- https://github.com/vllm-project/vllm/pull/14228
- https://github.com/vllm-project/vllm/security/advisories/GHSA-x3m8-f7g5-qhm7
Get alerted when CVE-2025-29783 or the next vulnerability affects your stack