What’s Vulnerable › Vulnerabilities
CVE-2025-29789: OpenEMR Has Directory Traversal in Load Code feature
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-25 · updated 2026-06-17
- Weakness: CWE-23
Description
OpenEMR is a free and open source electronic health records and medical practice management application. Versions prior to 7.3.0 are vulnerable to Directory Traversal in the Load Code feature. Version 7.3.0 contains a patch for the issue.
Affected products
- openemr: before 7.0.3 — fixed in 7.0.3
How to fix
Upgrade to a fixed version: openemr 7.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/commit/ef3bb7f84ebe8ef54d55416e587ec2fefd065489
- https://github.com/openemr/openemr/security/advisories/GHSA-ffpq-2wqj-v8ff
Get alerted when CVE-2025-29789 or the next vulnerability affects your stack