What’s Vulnerable › Vulnerabilities
CVE-2025-29897: Stack-based Buffer Overflow in qsyncsrv.cgi
- Severity: low (CVSS 2.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-15 · updated 2026-10-19
- Weakness: CWE-120
Description
A buffer copy without checking size of input vulnerability has been reported to affect Qsync Central. If a remote attacker gains a user account, they can then exploit the vulnerability to modify memory or crash processes. We have already fixed the vulnerability in the following version: Qsync Central 5.0.0.4 and later
Affected products
- QNAP Systems Inc. Qsync Central: from 5.0.x before 5.0.0.4 — fixed in 5.0.0.4
How to fix
Upgrade to a fixed version: QNAP Systems Inc. Qsync Central 5.0.0.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-29897 or the next vulnerability affects your stack