What’s Vulnerable › Vulnerabilities
CVE-2025-29926: The WikiManager REST API allows any user to create wikis
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-19 · updated 2026-06-17
- Weakness: CWE-285
Description
XWiki Platform is a generic wiki platform. Prior to 15.10.15, 16.4.6, and 16.10.0, any user can exploit the WikiManager REST API to create a new wiki, where the user could become an administrator and so performs other attacks on the farm. Note that this REST API is not bundled in XWiki Standard by default: it needs to be installed manually through the extension manager. The problem has been patched in versions 15.10.15, 16.4.6 and 16.10.0 of the REST module.
Affected products
- xwiki-platform: from 5.4.1 before 15.10.15; from 16.0.0 before 16.4.6; from 16.5.0 before 16.10.0; 5.4, 5.4-rc1 — fixed in 15.10.15, 16.10.0, 16.4.6
How to fix
Upgrade to a fixed version: xwiki-platform 15.10.15, 16.10.0, 16.4.6. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/82aa670106c7f5e6238ca6ed59a52d1800e05b99
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-gfp2-6qhm-7x43
- https://jira.xwiki.org/browse/XWIKI-22490
Get alerted when CVE-2025-29926 or the next vulnerability affects your stack