What’s Vulnerable › Vulnerabilities

CVE-2025-29927: Authorization Bypass in Next.js Middleware

Description

Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.

Affected products

How to fix

Upgrade to a fixed version: Next.js 12.3.5, 13.5.9, 14.2.25, 15.2.3; Npm Next 13.5.9, 14.2.25, 15.2.3, 12.3.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-29927 or the next vulnerability affects your stack