What’s Vulnerable › Vulnerabilities
CVE-2025-29983
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-15 · updated 2026-06-17
- Weakness: CWE-59
Description
Dell Trusted Device, versions prior to 7.0.3.0, contain an Improper Link Resolution Before File Access ('Link Following') vulnerability. A low privileged attacker with local access could potentially exploit this vulnerability, leading to Elevation of privileges.
Affected products
- Dell Trusted Device Client: before 7.0.3.0 — fixed in 7.0.3.0
How to fix
Upgrade to a fixed version: Dell Trusted Device Client 7.0.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-29983 or the next vulnerability affects your stack