What’s Vulnerable › Vulnerabilities
CVE-2025-30001: Apache StreamPark: Authenticated users can trigger remote command execution
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-10 · updated 2026-10-08
- Weakness: CWE-279
Description
Incorrect Execution-Assigned Permissions vulnerability in Apache StreamPark. This issue affects Apache StreamPark: from 2.1.4 before 2.1.6. Users are recommended to upgrade to version 2.1.6, which fixes the issue.
Affected products
- Apache Software Foundation Apache StreamPark: from 2.1.4 before 2.1.6 — fixed in 2.1.6
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache StreamPark 2.1.6. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/xfmsvhkcnr1831n0w5ovy3p44lsmfb7m
- http://www.openwall.com/lists/oss-security/2025/09/04/1
Get alerted when CVE-2025-30001 or the next vulnerability affects your stack