What’s Vulnerable › Vulnerabilities
CVE-2025-30067: Apache Kylin: The remote code execution via jdbc url
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-27 · updated 2026-06-17
- Weakness: CWE-94
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Kylin. If an attacker gets access to Kylin's system or project admin permission, the JDBC connection configuration maybe altered to execute arbitrary code from the remote. You are fine as long as the Kylin's system and project admin access is well protected. This issue affects Apache Kylin: from 4.0.0 through 5.0.1. Users are recommended to upgrade to version 5.0.2 or above, which fixes the issue.
Affected products
- Apache Software Foundation Apache Kylin: from 4.0.0 before 5.0.2 — fixed in 5.0.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Kylin 5.0.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/6j19pt8yoqfphf1lprtrzoqkvz1gwbnc
- http://www.openwall.com/lists/oss-security/2025/03/27/4
Get alerted when CVE-2025-30067 or the next vulnerability affects your stack