What’s Vulnerable › Vulnerabilities
CVE-2025-30145: GeoServer has an Infinite Loop Vulnerability in Jiffle process
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-10 · updated 2026-06-17
- Weakness: CWE-835
Description
GeoServer is an open source server that allows users to share and edit geospatial data. Malicious Jiffle scripts can be executed by GeoServer, either as a rendering transformation in WMS dynamic styles or as a WPS process, that can enter an infinite loop to trigger denial of service. This vulnerability is fixed in 2.27.0, 2.26.3, and 2.25.7. This vulnerability can be mitigated by disabling WMS dynamic styling and the Jiffle process.
Affected products
- geoserver org.geoserver.extension:gs-db2: before 2.25.7; from 2.26.0 before 2.26.3 — fixed in 2.25.7, 2.26.3
How to fix
Upgrade to a fixed version: geoserver org.geoserver.extension:gs-db2 2.25.7, 2.26.3. Check the vendor advisory for mitigations.
References
- https://github.com/geoserver/geoserver/security/advisories/GHSA-gr67-pwcv-76gf
- https://github.com/geosolutions-it/jai-ext/pull/307
- https://osgeo-org.atlassian.net/browse/GEOS-11778
Get alerted when CVE-2025-30145 or the next vulnerability affects your stack