What’s Vulnerable › Vulnerabilities
CVE-2025-30149: OpenEMR Reflected XSS in AJAX Script
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-79
Description
OpenEMR is a free and open source electronic health records and medical practice management application. OpenEMR allows reflected cross-site scripting (XSS) in the AJAX Script interface\super\layout_listitems_ajax.php via the target parameter. This vulnerability is fixed in 7.0.3.
Affected products
- openemr: before 7.0.3 — fixed in 7.0.3
How to fix
Upgrade to a fixed version: openemr 7.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/commit/6cb70595f65decfbdd03e70b49acc414e03744b8
- https://github.com/openemr/openemr/security/advisories/GHSA-fwfv-8583-6rr7
- https://github.com/openemr/openemr/security/advisories/GHSA-fwfv-8583-6rr7
Get alerted when CVE-2025-30149 or the next vulnerability affects your stack