What’s Vulnerable › Vulnerabilities
CVE-2025-30150: Shopware 6 allows attackers to check for registered accounts through the store-api
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-08 · updated 2026-06-17
- Weakness: CWE-204
Description
Shopware 6 is an open commerce platform based on Symfony Framework and Vue. Through the store-api it is possible as a attacker to check if a specific e-mail address has an account in the shop. Using the store-api endpoint /store-api/account/recovery-password you get the response, which indicates clearly that there is no account for this customer. In contrast you get a success response if the account was found. This vulnerability is fixed in Shopware 6.6.10.3 or 6.5.8.17. For older versions of 6.4, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
Affected products
- shopware: before 6.5.8.18; from 6.6.0.0 before 6.6.10.3; 6.7.0.0-rc1 — fixed in 6.5.8.18, 6.6.10.3
How to fix
Upgrade to a fixed version: shopware 6.5.8.18, 6.6.10.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-30150 or the next vulnerability affects your stack