What’s Vulnerable › Vulnerabilities
CVE-2025-30151: Shopware allows Denial Of Service via password length
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-08 · updated 2026-06-17
- Weakness: CWE-20
Description
Shopware is an open commerce platform. It's possible to pass long passwords that leads to Denial Of Service via forms in Storefront forms or Store-API. This vulnerability is fixed in 6.6.10.3 or 6.5.8.17. For older versions of 6.4, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
Affected products
- shopware: before 6.5.8.17; from 6.6.0.0 before 6.6.10.3; 6.7.0.0-rc1 — fixed in 6.5.8.17, 6.6.10.3
How to fix
Upgrade to a fixed version: shopware 6.5.8.17, 6.6.10.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-30151 or the next vulnerability affects your stack