What’s Vulnerable › Vulnerabilities
CVE-2025-30161: OpenEMR Stored XSS in OpenEMR Bronchitis Form
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-80
Description
OpenEMR is a free and open source electronic health records and medical practice management application. A stored XSS vulnerability in the Bronchitis form component of OpenEMR allows anyone who is able to edit a bronchitis form to steal credentials from administrators. This vulnerability is fixed in 7.0.3.
Affected products
- openemr: before 7.0.3 — fixed in 7.0.3
How to fix
Upgrade to a fixed version: openemr 7.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/blob/17ca5539bafcdc25a9042ebc14480552e07867e4/interface/forms/bronchitis/view.php#L102-L103
- https://github.com/openemr/openemr/blob/17ca5539bafcdc25a9042ebc14480552e07867e4/interface/forms/bronchitis/view.php#L303-L304
- https://github.com/openemr/openemr/security/advisories/GHSA-59rv-645x-rg6p
Get alerted when CVE-2025-30161 or the next vulnerability affects your stack