What’s Vulnerable › Vulnerabilities
CVE-2025-30162: East-west traffic not subject to egress policy enforcement for requests via Gateway API load balancers
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-24 · updated 2026-06-17
- Weakness: CWE-863
Description
Cilium is a networking, observability, and security solution with an eBPF-based dataplane. For Cilium users who use Gateway API for Ingress for some services and use LB-IPAM or BGP for LB Service implementation and use network policies to block egress traffic from workloads in a namespace to workloads in other namespaces, egress traffic from workloads covered by such network policies to LoadBalancers configured by `Gateway` resources will incorrectly be allowed. LoadBalancer resources not deployed via a Gateway API configuration are not affected by this issue. This issue affects: Cilium v1.15 between v1.15.0 and v1.15.14 inclusive, v1.16 between v1.16.0 and v1.16.7 inclusive, and v1.17 between v1.17.0 and v1.17.1 inclusive. This issue is fixed in Cilium v1.15.15, v1.16.8, and v1.17.2. A Clusterwide Cilium Network Policy can be used to work around this issue for users who are unable to upgrade.
Affected products
- cilium: from 1.15.0 before 1.15.15; from 1.16.0 before 1.16.8; from 1.17.0 before 1.17.2 — fixed in 1.15.15, 1.16.8, 1.17.2
How to fix
Upgrade to a fixed version: cilium 1.15.15, 1.16.8, 1.17.2. Check the vendor advisory for mitigations.
References
- https://docs.cilium.io/en/stable/network/lb-ipam
- https://github.com/cilium/cilium/security/advisories/GHSA-24qp-4xx8-3jvj
- https://github.com/cilium/proxy/pull/1172
Get alerted when CVE-2025-30162 or the next vulnerability affects your stack