What’s Vulnerable › Vulnerabilities
CVE-2025-30166: Pimcore's Admin Classic Bundle allows HTML Injection
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Pimcore's Admin Classic Bundle provides a Backend UI for Pimcore. An HTML injection issue allows users with access to the email sending functionality to inject arbitrary HTML code into emails sent via the admin interface, potentially leading to session cookie theft and the alteration of page content. The vulnerability was discovered in the /admin/email/send-test-email endpoint using the POST method. The vulnerable parameter is content, which permits the injection of arbitrary HTML code during the email sending process. While JavaScript code injection is blocked through filtering, HTML code injection remains possible. This vulnerability is fixed in 1.7.6.
Affected products
- pimcore admin-ui-classic-bundle: before 1.7.6 — fixed in 1.7.6
How to fix
Upgrade to a fixed version: pimcore admin-ui-classic-bundle 1.7.6. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/admin-ui-classic-bundle/commit/76b690d4f8fcd9c9d41766bc5238c2513242e60e
- https://github.com/pimcore/admin-ui-classic-bundle/security/advisories/GHSA-x82r-6j37-vrgg
Get alerted when CVE-2025-30166 or the next vulnerability affects your stack