What’s Vulnerable › Vulnerabilities

CVE-2025-30177: Apache Camel: Camel-Undertow Message Header Injection via Improper Filtering

Description

Bypass/Injection vulnerability in Apache Camel in Camel-Undertow component under particular conditions. This issue affects Apache Camel: from 4.10.0 before 4.10.3, from 4.8.0 before 4.8.6. Users are recommended to upgrade to version 4.10.3 for 4.10.x LTS and 4.8.6 for 4.8.x LTS. Camel undertow component is vulnerable to Camel message header injection, in particular the custom header filter strategy used by the component only filter the "out" direction, while it doesn't filter the "in" direction. This allows an attacker to include Camel specific headers that for some Camel components can alter the behaviour such as the camel-bean component, or the camel-exec component.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Camel 4.10.3, 4.8.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-30177 or the next vulnerability affects your stack