What’s Vulnerable › Vulnerabilities

CVE-2025-30179: MFA Enforcement Bypass in Search APIs

Description

Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8 fail to enforce MFA on certain search APIs, which allows authenticated attackers to bypass MFA protections via user search, channel search, or team search queries.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.3.4, 10.4.3, 9.11.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-30179 or the next vulnerability affects your stack