What’s Vulnerable › Vulnerabilities
CVE-2025-30194: Denial of service via crafted DoH exchange
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-29 · updated 2026-06-17
- Weakness: CWE-416
Description
When DNSdist is configured to provide DoH via the nghttp2 provider, an attacker can cause a denial of service by crafting a DoH exchange that triggers an illegal memory access (double-free) and crash of DNSdist, causing a denial of service. The remedy is: upgrade to the patched 1.9.9 version. A workaround is to temporarily switch to the h2o provider until DNSdist has been upgraded to a fixed version. We would like to thank Charles Howes for bringing this issue to our attention.
Affected products
- PowerDNS DNSdist: from 1.9.0 before 1.9.9 — fixed in 1.9.9
How to fix
Upgrade to a fixed version: PowerDNS DNSdist 1.9.9. Check the vendor advisory for mitigations.
References
- https://dnsdist.org/security-advisories/powerdns-advisory-for-dnsdist-2025-02.html
- http://www.openwall.com/lists/oss-security/2025/04/29/1
- https://www.vicarius.io/vsociety/posts/cve-2025-30194-detection-dnsdist-vulnerability
- https://www.vicarius.io/vsociety/posts/cve-2025-30194-mitigate-dnsdist-vulnerability
Get alerted when CVE-2025-30194 or the next vulnerability affects your stack