What’s Vulnerable › Vulnerabilities
CVE-2025-30202: Data exposure via ZeroMQ on multi-node vLLM deployment
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-30 · updated 2026-06-17
- Weakness: CWE-770
Description
vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.5.2 and prior to 0.8.5 are vulnerable to denial of service and data exposure via ZeroMQ on multi-node vLLM deployment. In a multi-node vLLM deployment, vLLM uses ZeroMQ for some multi-node communication purposes. The primary vLLM host opens an XPUB ZeroMQ socket and binds it to ALL interfaces. While the socket is always opened for a multi-node deployment, it is only used when doing tensor parallelism across multiple hosts. Any client with network access to this host can connect to this XPUB socket unless its port is blocked by a firewall. Once connected, these arbitrary clients will receive all of the same data broadcasted to all of the secondary vLLM hosts. This data is internal vLLM state information that is not useful to an attacker. By potentially connecting to this socket many times and not reading data published to them, an attacker can also cause a denial of service by slowing down or potentially blocking the publisher. This issue has been patched in version 0.8.5.
Affected products
- vllm-project vllm: from 0.5.2 before 0.8.5 — fixed in 0.8.5
How to fix
Upgrade to a fixed version: vllm-project vllm 0.8.5. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/a0304dc504c85f421d38ef47c64f83046a13641c
- https://github.com/vllm-project/vllm/pull/6183
- https://github.com/vllm-project/vllm/security/advisories/GHSA-9f8f-2vmf-885j
Get alerted when CVE-2025-30202 or the next vulnerability affects your stack