What’s Vulnerable › Vulnerabilities
CVE-2025-30203: Tuleap allows XSS via the content of RSS feeds in the RSS widgets
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-79
Description
Tuleap is an Open Source Suite to improve management of software developments and collaboration. Tuleap allows cross-site scripting (XSS) via the content of RSS feeds in the RSS widgets. A project administrator or someone with control over an used RSS feed could use this vulnerability to force victims to execute uncontrolled code. This vulnerability is fixed in Tuleap Community Edition 16.5.99.1742562878 and Tuleap Enterprise Edition 16.5-5 and 16.4-8.
Affected products
- Enalean tuleap: before 16.4-8; before 16.5.99.1742562878; from 16.5 before 16.5-5 — fixed in 16.4-8, 16.5-5, 16.5.99.1742562878
How to fix
Upgrade to a fixed version: Enalean tuleap 16.4-8, 16.5-5, 16.5.99.1742562878. Check the vendor advisory for mitigations.
References
- https://github.com/Enalean/tuleap/commit/54cce3f5e883d16055cb0239e023f48cdf5eb25f
- https://github.com/Enalean/tuleap/security/advisories/GHSA-39gx-34fc-rx6r
- https://tuleap.net/plugins/git/tuleap/tuleap/stable?a=commit&h=54cce3f5e883d16055cb0239e023f48cdf5eb25f
- https://tuleap.net/plugins/tracker/?aid=42243
Get alerted when CVE-2025-30203 or the next vulnerability affects your stack