What’s Vulnerable › Vulnerabilities
CVE-2025-30207: Kirby vulnerable to path traversal in the router for PHP's built-in server
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-13 · updated 2026-06-17
- Weakness: CWE-22
Description
Kirby is an open-source content management system. A vulnerability in versions prior to 3.9.8.3, 3.10.1.2, and 4.7.1 affects all Kirby setups that use PHP's built-in server. Such setups are commonly only used during local development. Sites that use other server software (such as Apache, nginx or Caddy) are not affected. A missing path traversal check allowed attackers to navigate all files on the server that were accessible to the PHP process, including files outside of the Kirby installation. The vulnerable implementation delegated all existing files to PHP, including existing files outside of the document root. This leads to a different response that allows attackers to determine whether the requested file exists. Because Kirby's router only delegates such requests to PHP and does not load or execute them, contents of the files were not exposed as PHP treats requests to files outside of the document root as invalid. The problem has been patched in Kirby 3.9.8.3, Kirby 3.10.1.2, and Kirby 4.7.1. In all of the mentioned releases, the maintainers of Kirby have updated the router to check if existing static files are within the document root. Requests to files outside the document root are treated as page requests of the error page and will no longer allow to determine whether the file exists or not.
Affected products
- getkirby kirby: before 3.9.8.3; from 3.10.0 before 3.10.1.2; from 4.0.0 before 4.7.1 — fixed in 3.10.1.2, 3.9.8.3, 4.7.1
How to fix
Upgrade to a fixed version: getkirby kirby 3.10.1.2, 3.9.8.3, 4.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/getkirby/kirby/releases/tag/3.10.1.2
- https://github.com/getkirby/kirby/releases/tag/3.9.8.3
- https://github.com/getkirby/kirby/releases/tag/4.7.1
- https://github.com/getkirby/kirby/security/advisories/GHSA-9p3p-w5jf-8xxg
Get alerted when CVE-2025-30207 or the next vulnerability affects your stack