What’s Vulnerable › Vulnerabilities

CVE-2025-30208: Vite bypasses server.fs.deny when using `?raw??`

Description

Vite, a provider of frontend development tooling, has a vulnerability in versions prior to 6.2.3, 6.1.2, 6.0.12, 5.4.15, and 4.5.10. `@fs` denies access to files outside of Vite serving allow list. Adding `?raw??` or `?import&raw??` to the URL bypasses this limitation and returns the file content if it exists. This bypass exists because trailing separators such as `?` are removed in several places, but are not accounted for in query string regexes. The contents of arbitrary files can be returned to the browser. Only apps explicitly exposing the Vite dev server to the network (using `--host` or `server.host` config option) are affected. Versions 6.2.3, 6.1.2, 6.0.12, 5.4.15, and 4.5.10 fix the issue.

Affected products

How to fix

Upgrade to a fixed version: vitejs vite 4.5.10, 5.4.15, 6.0.12, 6.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-30208 or the next vulnerability affects your stack