What’s Vulnerable › Vulnerabilities
CVE-2025-30213: Frappe has Possibility of Remote Code Execution due to improper validation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-25 · updated 2026-06-17
- Weakness: CWE-20
Description
Frappe is a full-stack web application framework. Prior to versions 14.91.0 and 15.52.0, a system user was able to create certain documents in a specific way that could lead to remote code execution. Versions 14.9.1 and 15.52.0 contain a patch for the vulnerability. There's no workaround; an upgrade is required.
Affected products
- frappe: before 14.91.0; from 15.0.0 before 15.52.0 — fixed in 14.91.0, 15.52.0
How to fix
Upgrade to a fixed version: frappe 14.91.0, 15.52.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-30213 or the next vulnerability affects your stack