What’s Vulnerable › Vulnerabilities
CVE-2025-30214: Frappe vulnerable to information disclosure leading to account takeover
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-25 · updated 2026-06-17
- Weakness: CWE-200
Description
Frappe is a full-stack web application framework. Prior to versions 14.89.0 and 15.51.0, making crafted requests could lead to information disclosure that could further lead to account takeover. Versions 14.89.0 and 15.51.0 fix the issue. There's no workaround to fix this without upgrading.
Affected products
- frappe: before 14.89.0; from 15.0.0 before 15.51.0 — fixed in 14.89.0, 15.51.0
How to fix
Upgrade to a fixed version: frappe 14.89.0, 15.51.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-30214 or the next vulnerability affects your stack